Scheduled for November 26, 2025 at 9:00 PM – 10:14 PM
Affects
Sites
Under maintenance from 9:00 PM to 10:14 PM
Website
Under maintenance from 9:00 PM to 10:14 PM
Completed
November 26, 2025 at 10:14 PMCompleted
November 26, 2025 at 10:14 PMMaintenance has completed successfully.
In progress
November 26, 2025 at 9:43 PMIn progress
November 26, 2025 at 9:43 PMThe client-area has succesfully been implemented, we are currently setting up new website!
Update
November 26, 2025 at 9:00 PMUpdate
November 26, 2025 at 9:00 PMWe’re performing a major upgrade as we launch our brand-new FlexyNode front-end and back-end platform.
⏱ Scheduled time:
Today at 22:00 (CET)
During this maintenance window, the main website and client area will be temporarily offline. The status page will remain available, and we’ll post updates there throughout the rollout.
What’s affected:
• Main website
• Client area
What’s NOT affected:
• Game servers
• Panels
• All running services
• Status page
We’re genuinely excited to show you the new platform. Thanks for your patience while we bring everything online.
Planned
November 26, 2025 at 9:00 PMPlanned
November 26, 2025 at 9:00 PMWe’re performing a major upgrade as we launch our brand-new FlexyNode front-end and back-end platform.
⏱ Scheduled time:
Today at 22:00 (CET)
During this maintenance window, the main website and client area will be temporarily offline. The status page will remain available, and we’ll post updates there throughout the rollout.
What’s affected:
• Main website
• Client area
What’s NOT affected:
• Game servers
• Panels
• All running services
• Status page
We’re genuinely excited to show you the new platform. Thanks for your patience while we bring everything online.