FlexyNode - Discord bots on gamenode01 – Incident details

Web01 experiencing major outage

Discord bots on gamenode01

Resolved
Degraded performance
Started 11 days agoLasted 33 minutes

Affected

Game Servers

Degraded performance from 4:35 PM to 5:08 PM

GameNode 01

Degraded performance from 4:35 PM to 5:08 PM

Updates
  • Resolved
    UTC
    Resolved

    Discord has lifted the block on the outgoing IP address of gamenode01. We have removed our own block and all bots are able to connect again.

    If your bot is still offline, restart it once and it should come online normally. There is no need to change anything in your code or your token.

    Thanks for your patience.

  • Update
    UTC
    Update

    Discord has temporarily blocked the outgoing IP address of gamenode01 due to rate limiting on their side. Bots on this node cannot complete the login to Discord because of this. This is not caused by your bot or your token.

    To help the block expire, we have temporarily blocked outgoing Discord traffic on gamenode01 ourselves. Every connection attempt keeps the block alive on Discord's side.

    This means bots that were still working earlier have now lost their Discord connection as well. That is expected and temporary. Other traffic from your server, such as downloads and other APIs, works normally.

    As soon as Discord lifts the block we will remove ours and the bots will come back online. This does not happen automatically, we do it manually and will report it here.

  • Identified
    UTC
    Identified

    We have identified the issue and are currently working on resolving it. This means that Discord bots can be taken offline.

  • Investigating
    UTC
    Investigating

    On gamenode01, Discord bots are currently having trouble reconnecting.

    Bots that are already running and connected continue to work normally; you won't notice anything.

    The problem only occurs with bots that are restarting right now: they load their commands and events normally, but then get stuck when trying to log into Discord.

    The best thing to do: do not restart your bot for a while.

    Is it still running? Then leave it running, even if you wanted to roll out an update - postpone that for a moment. If you have just restarted and it isn't coming online, just let it run: it will connect automatically as soon as it can again. Repeatedly restarting does not help and can make it take longer.

    You do not need to change anything in your code or your token. It does not seem to be due to individual bots; it is affecting multiple bots on this node simultaneously. Other services and other nodes are not affected.

    What we are doing

    We are investigating the source of the problem and will let you know here as soon as there is news,

    or as soon as things are running normally again.