Scheduled for January 09, 2026 at 6:00 PM – 11:00 PM
Affects
Sites
Under maintenance from 6:00 PM to 11:00 PM
Gamepanel
Under maintenance from 6:00 PM to 11:00 PM
Completed
January 09, 2026 at 11:00 PMCompleted
January 09, 2026 at 11:00 PMMaintenance has completed successfully
In progress
January 09, 2026 at 6:00 PMIn progress
January 09, 2026 at 6:00 PMMaintenance is now in progress
Planned
January 09, 2026 at 6:00 PMPlanned
January 09, 2026 at 6:00 PMWe’re performing maintenance on our gamepanel.
⏱ Scheduled time:
09-01-2026 at 19:00 (CET)
During this maintenance window, the gamepanel will be temporarily offline. The gameservers will remain online.
We’ll post updates here throughout the maintenance.
What’s affected:
• Gamepanel